Re: [S] Is this really good programming practice?

Jeffrey J. Hallman (m1jjh00@Frb.GOV)
Fri, 27 Mar 1998 10:43:54 -0500

>>>>> "BV" == Bill Venables <> writes:
[ an explanation of lazy evaluation ]

But is it good style? Well, you can always look at the code to see what's
going on, can't you?

> grep("eta", as.character(glm[[length(glm)]]))


At the very least, I think the documentation for glm() should say what the
default value for 'start' is. And it wouldn't hurt at all for 'eta' to have a
longer, more descriptive name.

Really, clarity of the code is almost always more important than execution
efficiency, and it's always more important than saving keystrokes for the


This message was distributed by To unsubscribe
send e-mail to with the BODY of the
message: unsubscribe s-news